Up2date User Guide
Maintain web site
 


GETTING STARTED

Requirements and settings

To maintain your website using the online editor, you must be on a PC (not a Macintosh) and have Internet Explorer Version 5.5 or above. If you don’t have a current version of Internet Explorer, you can download it free from Microsoft’s website: http://microsoft.com/windows/ie/default.htm.

Important 
Do not “copy/paste” from any programs, make the changes in Up2date, or paste your content in note-pad before pasting in Up2date
Logging in

To start creating your website, you need to log into your account. The main reason you need to login is so that only you can access your files. Generally, each user is given their own username, and password. Your username may be (or contain) your name or any other sequence of characters. A username is required so that the program knows who you are if there are multiple users, and is able to let each user access their corresponding files. Other users may know your username, but you should keep your password confidential so as to not enable anyone else to access your files. (Your username and password will be assigned to you by your administrator). 

To Login simply:


1. Enter your username and password and

2. Click the ‘Login Now’ button. 

If you are having problems logging in:


· Check that your CAPS-LOCK key is NOT on (as the login and password are case sensitive – e.g. entering ‘John’ is different to entering ‘john’) and 


· Ensure you are entering the correct username and password. 

If you are still getting an error message, you may have to contact your administrator to re-set your password.

When you login successfully, you can choose how you want to edit your web site.

Logging out

Logging out means that you will exit the web site editor and have to log back in to access your files. The files will be updated to the last point where you chose the ‘save’ option. To Logout:

1. Click the 'Logout' link from the left frame in the web site editor. 

 EDITING YOUR WEB SITE IN UP2DATE
You will see your web files and web folders. 

· You will see the size and the date last modified shown for each file and folder

· You will see that the row is highlighted for the file/folder your cursor is pointing on

· You can perform general maintenance on your site from the File Manager 

· When you put your mouse over certain text, a comment will appear which tells you what clicking on the link will do.
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File types that are not editable (any file type that is NOT HTML) displays a greyed-out ‘edit’ link.

Up2date allows you to organize your files into relevant groups of folders. Our online application has a very simple to use, yet powerful file manager that makes it easy to organize your files and folders.

All folders are represented with the folder [image: image59.png]Are you sure you wish to delete?
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 icon and files with the file icon [image: image2.emf]


With Files you can:

	- Upload
	- View
	- Delete

	- Create
	- Rename
	- Copy


With Folders you can:

	- Create
	- Rename
	- Copy

	- Delete
	
	


The Current Working Directory is located at the top of the File Manager page. This will at all times reflect your current location in the file system. (The current folder you are in). The Current Working Directory helps you to keep track of where you are in the file system as you navigate your way through folders. 

If you are allowed to go back up a folder, you will see a '[ Up One Level ]' link. Select this link to go back up a folder. If you do not see this link, then you are in your home directory.

Creating a New Folder

To create a new folder:

1. Click the 'Create Folder' button at the top of the File Manager page. This will take you to another screen that prompts you to enter a name for the new folder.

2. Enter the name you want to call your folder and click 'OK', or click 'Cancel' to go back to the File Manager. Valid folder names can only contain:


- Alphanumeric characters (a-z, A-Z 0-9)


- The underscore '_' 


- A dash '-'

If the name of the folder you are creating already exists, you will get an error message and you will need to choose another name for the folder:

Once your folder has been successfully created, you will receive the following message: 

Directory newsfolder Created Successfully
Changing into a folder

You may need to change into a folder to view, edit, copy or delete the files that are in that folder.

To change into a folder:

1. Select the desired folder and click on the folder's underlined name.

The Current Working Directory (located just on top of your folder and file listing) will change to reflect your current folder.

Creating a New Page
To create a new page:

If you want to create a new page the best thing to do is to take a copy of an already made page. This way you are sure that all your pages have the same design and fonts.

To create a new page without the same design you can:

1. Click the 'Create New Page' button at the top of the File Manager. This will take you to another screen that has a list of templates you can use on a page.

2. A thumbnail sized preview of the templates available appears on the right for you to select from. Once you have selected a template, enter a name for the new file and optionally a page title, description and keywrods. Valid file names can only contain: 



- Alphanumeric characters (a-z, A-Z 0-9)


- The underscore '_' 


- A dash '-'

3. To create the file once you have entered the new file name, click 'OK' or Click 'Cancel' to go back to the File Manager. Click the ‘Preview’ button to see how the file will look in your web browser.

The file’s extension is required, so always enter it. For example, use ‘new.html’ as your page name.

If you entered an invalid file name, an error message will appear and you will need to enter a valid filename:


If you entered a filename that already exists, you will get the following error message and you will need to enter another file name that doesn’t already exist:

Uploading a File


To upload a file

1. Click the 'Upload File' button at the top of the File Manager. This will take you to another screen that requires a file to upload. To upload a file to a folder, make sure you are in the folder when clicking ‘Upload File’. 

2.
Click the 'Browse' button to open a 'Choose File' box that allows you to select a local file to upload.

3. Once the file has been selected, click 'OK' to begin uploading the file, or click 'Cancel' to be taken back to the File Manager.

NB: Uploads may take a minute or two depending on the speed of your internet connection.

If the file is in an invalid format anror message will appear:

If the name of the file you are uploading already exists, you will get an error message and you will need to rename the file before uploading it.
Once your file has been successfully uploaded, you will receive the following message: uploaded successfully
Viewing a File 

To view a file

1. Select the desired file and click on the view [image: image3.emf]

 icon. The file will be shown in a pop-up window.

2. Close the window to return to the File Manager.

Editing a File

To edit a file

1. Select the desired file and click on the 'Edit' [image: image4.emf]

 icon. You will be taken to the WYSIWYG Editor screen.

A full description of WYSIWYG editor commands can be found in the following section titled “Features within the editor – Editor commands”.

NB: Only HTML files can be edited. Image files will have the ‘edit’ icon greyed out. 


Renaming a File or Folder


When creating a file or folder, you may have chosen a name that you then decide is not appropriate or needs to be changed to reflect its contents or context better. The ‘rename’ function will allow you to easily change the name of the file or folder as you require.


To rename:

1. Locate the desired file / folder and click on the rename [image: image5.emf]

 icon. This will take you to another screen that requires a new name for the file / folder.


2. Enter a valid name and click 'OK' to rename, or click 'Cancel' to be taken back to the File Manager.

If the new file name you entered an invalid file name, an error message will appear and you will need to enter a valid filename:

· For Folders, simply rename the folder to a name of your choice, without any extensions.

If the new file or folder name you entered already exists, you will receive an error message and you will need to enter another name for the new file/folder name: A file or a folder with that name already exists.
Once your file or folder has been successfully created, you will receive the following message: renamed succesfully
Deleting a File or Folder

You may no longer have a need for a certain file or folder. You can choose to keep it, or if you are sure it doesn’t need to be used again, you can PERMANENTLY delete it. Only use the delete function if you are sure you do not need the file/folder and its contents.

To delete a file or folder:

1. Locate the desired file or folder and click on the delete [image: image6.emf]

 icon. You will be prompted for confirmation of the deletion.



2. If you are sure you wish to delete the selected file/folder, click 'OK'.
Clicking on 'Cancel' will take you back to the File Manager.

Copying a File or Folder

If you need two or more files that are similar, or need to copy the contents of a file or folder to make modifications, you may need to copy them.

To copy a file or folder:  

1. Click on the copy [image: image7.emf]

 icon corresponding to the file or folder that you wish to copy.

2. For files: Enter the name of the new file you wish to copy to, in the format filename.extension
For folders: Enter the name of the new folder that you wish to copy to.

3. Click on ‘Ok’ to copy (Or Click ‘cancel’ to return to the previous screen)

For files, if the new file name you entered an invalid file name, an error message will appear and you will need to enter a valid filename:

If the new file or folder name you entered already exists, you will receive an error message and you will need to enter another name for the new file/folder name:

Once your file or folder has been successfully created, you will receive the following message: Copied successfully



FEATURES WITHIN THE EDITOR
The Editor Toolbar

The tool for editing your web pages is the editor. The editor has a toolbar – this is a row of icons on along the top of the editor page and each activates different commands or functions when clicked. Some have drop-down lists which allows you to view all the functions associated with the icon.

When moving your mouse over each icon, you will notice that text will appear which indicates the function and title of the icon. To get information on the functionality of this icon, look up the name.
Editor Commands

This section will list all the icons listed in the editor toolbar. You will find the command title in bold, a description of the command in italic below the title, followed by the icon that appears in the toolbar for that command (left) and a step-by-step outline on how to perform the particular command.

Some commands have shortcut keys. Shortcut keys are usually a combination of holding the ‘ctrl’ (control) key on your keyboard down with another key. These are handy shortcuts for when you become more familiar with the commands and want to perform the more common ones quickly without going through the editor. A full list of shortcut keys are provided in the section titled ‘Shortcut Keys Index’ and you will notice the shortcut keys noted in bold in the following list of commands
(where applicable).

	Save

It is important to save your work at regular intervals in case there is a computer crash, power failure or such that may cause your computer to shutdown. In such a situation, you will loose any unsaved work. 
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	To save changes you have made to a file (without exiting) you can either:

Click the 'Save' icon or 

Use a shortcut to save: ‘ctrl + s’
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To save changes you have made to a file and exit:

Click the ‘save and exit’ icon

The file will be saved and you will be taken back to the File Manager.

	
	
	

	Cancel without Saving

If you make changes to a file and then decide that you do not want to save the changes, then you will need to cancel without saving.
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To cancel changes without saving

1. Click the 'Cancel Without Saving' icon. A dialog box will appear, asking for confirmation. You will be asked “Are you sure you want to cancel without saving changing?”

2. Answering “Ok” will take you back to where you were before entering the editor

3. Answering “Cancel” will keep you in the file and will not discard your changes.



	
Cut 

If you need to remove a section of text (either to paste somewhere else or delete), you would use this feature. 
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	To cut a portion of the document (image or text):

1. Highlight the desired portion and click the Edit menu then click the 'Cut' option (keyboard shortcut –  Ctrl + x),
or

2. Click the right mouse button on the desired portion and choose ‘cut’ 



	Copy

If you want to copy of a certain section of text, and you don’t want to re-write it, or if you want a copy of an image that is already on the page and don’t want to go through the process of inserting it,

then you can use the copy command.
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	To copy a portion of the document: 

1. Highlight the desired portion and click the Edit menu then click the ‘Copy’ option (keyboard shortcut - ctrl+c), or

2. Click the right mouse button on the desired portion and choose ‘copy’

If you want to copy multiple items that can’t be highlighted together with the cursor, then hold down the control key and highlight the areas you need copying with the mouse cursor.



	Paste

This command allows you to paste the last copied item or items to the position of your cursor.
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	To paste a portion that has already been cut (or copied):

1. Click where you want to place the desired portion on the page and 

2. Click the Edit menu then click the ‘Paste’ option (keyboard shortcut – ctrl+v), or

3. Click the right mouse button on the desired portion and choose ‘paste’ 



	
Undo

This command allows you to undo the last operation you performed (unless it’s a ‘save’). This is useful if you have performed an incorrect operation or one that you don’t want to save.
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	To undo the last change:

1. Click the Edit menu then click the 'Undo' option (keyboard shortcut – ctrl+z).  

Each consecutive click will undo the previous change to the document.



	
Redo

This command allows you to undo your last undo, hence redo it. It is essentially the opposite of an undo.
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	To redo the last change:

1. Click the Edit menu then click the 'Redo' option (keyboard shortcut - ctrl+y). 

Each consecutive click will repeat the last change to the document.



	
Bold

Bolding text makes it stand out from normal body text. It increases the thickness of the lettering. For example ‘edit’ is not bold, and ‘edit’ is bold. You can bold text that you want to stand out such as headings and keywords.  
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	To bold text:

1. Select the desired portion of text & click the 'Bold' icon (keyboard shortcut – ctrl + b). 

· Each consecutive click will toggle this function on and off.

· To find out whether existing text is bold, highlight the text with the cursor. If the ‘bold’ button is indented, then the text has been formatted to ‘bold’



	Underline

Underlining places a line under the selected text. Like bold, this is also a way to make text stand out more and can be used on text that you want to stand out more such as headings and keywords. eg. ‘edit’ is underlined, & ‘edit’ is not. 
  

	
	 
	To underline text: 

1. Select the desired text & click the 'Underline' icon (keyboard shortcut – ctrl+u). 

· Each consecutive click will toggle this function on and off.

· To find out whether existing text is underlined, highlight the text with the cursor. If the ‘underline’ button is indented, then the text has been formatted to ‘underline’



	Italic

Making text italic makes the letters of the selected text slant to the right. E.g. ‘edit’ is italic, ‘edit’ is not.
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	To convert text to italic:

1. Select the desired portion of text and click the 'Italic' icon (keyboard shortcut – ctrl+ i).  

· Each consecutive click will toggle this function on and off.

· To find out whether existing text is italic, highlight the text with the cursor. If the ‘italic’ button is indented, then the text has been formatted to ‘italic’



	Superscript

Superscript is a character that is printed above & immediately to one side of another. eg. in ‘x2’ the superscript is 2.
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	To convert text to superscript (vertically aligned higher):

1. Select the desired portion of text and click the Format menu then click the 'superscript' option.  Each consecutive click will toggle this function on and off.



	Subscript

A symbol or character written directly beneath, next to & below a letter or number. eg. in ‘x2’ the subscript is X
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	To convert text to subscript (vertically aligned lower):

1. Select the desired portion of text and click the Format menu then click the 'subscript' option.  Each consecutive click will toggle this function on and off.



	Insert Number List

This command is useful when you have rows of print in sections and you need to number and list them. Text being typed is inserted into a bulleted list. In the following example: 

“the document comes in two formats:

filename.doc

filename.pdf”

‘.doc’ and .’pdf’ can be highlighted and a numbered list inserted to create, where a number prefixes each listed item:

“the document comes in two formats:

1. filename..doc

2. filename.pdf”
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	To start a numbered text list:

1. Click the 'Insert Numbered List' icon. If text has already been selected, the selection will be converted to a numbered list. 

Each consecutive click will toggle this function on and off.



	Insert Bullet List

As in the previous command, the highlighted consecutive items are sorted into a list. Text being typed is inserted into a bulleted list. In the previous example they were sorted with numbers, in this command they are numbered with bullets which are defining dots that prefix each listed item. From the previous example, inserting a bulleted list would produce:

“the document comes in two formats:

· filename..doc

· filename.pdf”
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	To start a bullet text list:

1. Click the 'Insert Bullet List' icon. If text has already been selected, the selection will be converted to a bullet list. 

Each consecutive click will toggle this function on and off.



	Outdent

This command enables you to remove an indent (or tab) of text. 
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	To decrease indent of a paragraph:

1. Highlight the portion of text needing indenting.
2. Click the Format menu and then click the 'outdent' option. 
Each consecutive click will move text further to the left.



	Increase Indent

This command enables you to indent (or tab) portions of text by equal units in consecutive right spaces. This allows text to be organized into sections and look tidier and aligned.  
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	To increase indent of a paragraph:


1. Highlight the portion of text needing indenting.

2. Click the Format menu and then click the 'indent' option. 

Each consecutive click will move text further to the right.



	Align Left

This command enables you to align existing sections of text or text being written to a defined left border of the page or cell. This formatting can be used for headings and body text.
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	To align to the left:

1. Make a selection in the document and click the 'Align Left' icon. 



	Align Center

This command enables you to align existing sections of text or text being written, to the center of the page or cell. This formatting can be used for and body text but is mainly used for headings.
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	To align to the center:

1. Make a selection in the document and click the 'Align Center' icon.



	Align Right

This command enables you to align existing sections of text or text being written to a defined right border of the page or cell. This formatting can be used for headings and body text.
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	To align to the right:

1. Make a selection in the document and click the 'Align Right' icon.



	Align Justify

This command enables you to align existing sections of text or text being written to a defined left and right border of the page or cell. This formatting is usually used for body text.

	[image: image27.png]Blgn Justiy (Ctr)|





	 
	To align justify:

1. Select the location to insert the line and click the 'Align Justify' icon.



	Insert Horizontal Line

This command enables you to separate sections of the page with the insertion of a horizontal line.
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	To insert a horizontal line:


1. Select the location to insert the line and click the Insert menu then click the 'Horizontal Line' option.



	Create / Modify HyperLink

A hyperlink is a reference or link from one particular point in a web page file to particular point in another file OR another place in the same file. When a user clicks on the link in your web page with the mouse, the browser will display the target of the link This feature is useful for when you want to sort your website into different sections or pages and reference them easily or if you want your website to contain links to other pages in other sites. A URL is used to reference a section of another web page, a section of another website, or an anchor (see the anchor command).

After entering a hyperlink you may then need to modify it for example if the target link address changes. The modify operation allows you to modify the chosen hyperlink.
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	To create a hyperlink:

1. Select text/image to create the link on

2. Click the 'Create / Modify HyperLink' icon. A HyperLink window will appear, split into two sections. The top section ('Link Information') will have existing link information, if the object you selected already had a link. 

· You can also type the full URL of the page you want to link to in the URL text box. 

· You can also enter the target window information (optional) and an anchor name (if linking to an anchor - optional). This is if you want to reference a different section of the same file.

· You can specify the file extension you need.

The bottom section contains a cut-down version of the 'File Manager'. You can use this to navigate through your site's files and folders. When you have found the file you want to link to, click the 'Get Link Location' link next to that page. The information will be automatically updated in the 'Link Information' portion of the page. 

3. When finished, click the 'Insert Link' button to insert the HyperLink you just created, or click 'Remove Link' to remove an existing link. 

4. Clicking 'Cancel' will close the window and take you back to the editor.

5. To modify an existing hyperlink, select the link and click on the 'Create / Modify HyperLink' icon. The HyperLink window will appear. 

6. Make your changes and select the 'Insert Link' button. 

7. Select ‘remove link’ to remove an existing link.

	Insert / Modify Anchor

Inserting an anchor allows you to specify the place on the file where you can then reference it from another point in the document through a hyperlink (you have to name each anchor). This will be useful in situations where there are relating sections of information, that aren’t necessarily displayed in one spot or if you want users to be taken to a particular place in the page when they reach a certain point. For example, you could insert an anchor to the top of a file, and call it ‘top’. At the bottom of a page you could insert a hyperlink called “go to top of page”. If someone viewing your website had to scroll down the page, and at the bottom of the page came across “go to top of page”, then they could click on it, and get taken to the point of the anchor (which was placed at the top of the page). When inserting a hyperlink, you can choose from the anchors you have inserted from a drop down menu of anchors you have placed (if applicable).  
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	To insert an anchor:

1. Select a desired spot on the web page you are editing and click the Insert menu then click the 'Anchor…' option. In the dialogue box, type the name for the anchor.

2. When finished, click the 'Insert Anchor' button to insert the anchor, or 'Cancel' to close the box.

3. To modify an anchor select the Anchor (displayed as small yellow box when Guidelines are switched on)

4. Click on the Insert menu then click on the ‘Anchor…’ option. 

5. Make your changes and hit the 'Modify Anchor' button or click 'Cancel' to close the window.



	Create Email Link

This command will allow you to choose text or image which when clicked on, would open the user’s default email program (such as outlook) and create a new message. The ‘To’ field would automatically contain the email address you specify, and the ‘subject’ field of the new email message would contain the subject entered when creating the email link. This makes it easier for users that use your site and need to email a particular person or department by automating the process where the user has to go to their email program, create a new message, and type the email address in.   
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	To create an email link: 

1. Select text or an image on the web page you are editing where you would like the link to appear. 

2. Click the Insert menu then click the Link sub-menu. Finally, click the 'Email Address…' option. 

3. In the dialogue box, type the email address for the link and the subject of the email.

4. When finished, click the 'Insert Link' button to insert the email link, or 'Cancel' to close the box.



	Insert / Modify Image

This command allows you to browse the images you have available and insert them into a particular section of the page you are editing. This means that you can display any of the images available to you on your web page.

	
	 
	This will open the Image Manager. See the section titled Image Manager for more information.



	Font

This menu allows you to choose the style of font for the text that you specify.
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To change the font type of text:

1. Select the desired portion of text and click the 'Font' drop-down menu. 

2. Select the desired font (choose from Default - Times New Roman, Arial, Verdana, Tahoma, Courier New, Georgia).

To find the type of font of existing text, highlight the specific text and look at the ‘font’ menu. The font menu will change to indicate the type of font used



	Font Size

This menu allows you to choose the size of font for the text that you specify.
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To change the size of text:

1. Select the desired portion of text and click the 'Size' drop-down menu.

2. Select the desired size (text size 1-7).

To find the font size of existing text, highlight the specific text and look at the ‘font size’ menu. The font size menu will change to indicate the size of the font used



	Font Color

This menu allows you to choose the color of font for the text that you specify. It allows you to format the text in your page to match the style of your web page and distinguish heading from body text etc
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To change the color of text:

1. Select the desired portion of text and 

2. Click the 'Color' drop-down menu.

3. Select the desired color from the large selection in the drop-down menu.

To find the font color of existing text, highlight the specific text and look at the ‘font color’ menu. The font color menu will change to indicate the font color used.



	Highlight Font

This menu allows you to choose the highlight text that you specify. It allows you to format the text in your page to distinguish sections that you want to stand out.
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To highlight font:

1. Select the desired portion of text and 

2. Click the 'Highlight' drop-down menu.

3. Select the desired color from the large selection in the drop-down menu.



	Remove Text Formatting

This command allows you to select a specific portion of text and remove any of the formatting which it contains – leaving it with font style ‘Times New Roman’, format ‘Normal’ and font size ‘3’.
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To any text formatting to the default Times New Roman, Normal, size 3 font:

1. Select the desired portion of text and 

2. Click the Tools menu and then click the 'Remove Text Formatting' option.




	Style

The values in this box are predefined styles that are called from a stylesheet. This allows you to keep styles for your site on hand to be reused throughout your website for consistency.

	[image: image37.png]



 

To change the style of text, images, form objects, tables, table cells etc:

1. Select the desired element and click the 'Style' drop-down menu, which will display all styles defined in the style-sheet. Select the desired style from the menu.

Note: this function will not work if there is no style-sheet applied to the page.



	Insert Table 

A table can be a collection of text or images arranged in rows and columns. You can add images or text to a table, shade it, use headings etc. Each row & column interval is called a cell. You can choose to use to use a table with the cells visible on the website, or invisible and only evident to you whilst editing for the sake of aiding the organization of its contents.
eg. a company may insert a table with 3 columns and x rows to display their products. The first column may contain images of the products, the next column on the same row may contain the product description, and the last column on the same row may contain the product price.

In the editor the following attributes have the following properties:

Row: allows you to specify how many rows are required in your table

Column: allows you to specify how many columns are required in your table

Width: allows you to specify what percentage of the page section the width of the table will span

Bgcolor: allows you to specify the background color of the table

Cell spacing: allows you to specify the size of the spacing between each cells

Cell padding: allows you to specify the size of the space that will be left clear between the wall of the cell and the contents of the cell.

Border: allows you to specify the width of the border.
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	To insert a table: 

1. Select the desired location, and click the 'Insert Table' drop down icon (ctrl + t).

A new window will pop-up with the following fields: Rows - number of rows in table; Columns - number of columns in table; Width - width of table; BgColor - background color of table; Cell Padding - padding around cells; Cell Spacing - spacing between cells and Border - border around cells.

2. Fill in table details then click the 'Insert Table' button to insert table, or click 'Cancel' to go back to the editor.

To access any of the following table features, either click on the ‘table’ drop down menu, or click the right mouse button ensuring that the mouse cursor is within the table.



	Modify Table Properties

This command allows you to change the properties that were specified when the table was first created.
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	To modify table properties: 

1. Select a table or click anywhere inside the table to modify, then click the 'Modify Table Properties' icon.  A pop-up window will appear with the table's properties. 

2. Click the 'Modify Table Properties' button to save your changes, or click 'Cancel' to go back to the editor.


Note: this function will not work if a table has not been selected.



	Modify Cell Properties

This command allows you to modify the properties the cell of the table selected.
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	To modify cell properties:

1. Click inside the cell to modify, then click the 'Modify Cell Properties' icon.  A pop-up window will appear with the cells' properties.


2. Click the 'Modify Cell Properties' button to save your changes, or click 'Cancel' to go back to the editor.


Note: this function will not work if a cell has not been selected and does not work across multiple cells.



	Insert Row Above

You may find that after creating a table, you need to add an additional row. Instead of creating another table from scratch, you can add a row where you need. 
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	To insert row above:

1. Click inside cell above which to insert a row,

2. Click the Table menu and ten click the 'Insert Row Above' option.


Each consecutive click will insert another row above the selected cell.

Note: this function will not work if a cell has not been selected.



	Insert Row Below

You may find that after creating a table, you need to add an additional row. Instead of creating another table from scratch, you can add a row where you need.
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	To insert row below:

1. Click inside cell below which to insert a row

2. Click the Table menu and ten click the 'Insert Row Below' option.


Each consecutive click will insert another row below the selected cell.

Note: this function will not work if a cell has not been selected.



	Delete Row

You may find that after creating a table, you need to delete row from a table that is no longer needed.
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	To delete a row:

1. Click inside cell which is in the row to be deleted

2. Click the Table menu and ten click the 'Delete Row' option.

Note: this function will not work if a cell has not been selected.



	Insert Column to the right

You may find that after creating a table, you need to add an additional column. Instead of creating another table from scratch, you can add a column where you need.
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	To insert column after:

1. Click inside cell after which to insert a column

2. Click the Table menu and ten click the 'Insert Column After' option.


Each consecutive click will insert another column after the selected cell.

Note: this function will not work if a cell has not been selected.



	Insert Column to the left

You may find that after creating a table, you need to add an additional column. Instead of creating another table from scratch, you can add a column where you need.

	[image: image45.png]Modify Cell Froperties.
Insett Column to the Right

Insett Row Above





	 
	To insert column before: 

1. Click inside cell before which to insert a column c

2. Click the Table menu and ten click the 'Insert Column After' option.


Each consecutive click will insert another column before the selected cell.

Note: this function will not work if a cell has not been selected.



	Delete Column

You may find that after creating a table, you need to delete column from a table that is no longer needed.
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	To delete a column:

1. Click inside cell which is in the column to be deleted

2. Click the Table menu and ten click the 'Delete Column' option.


Note: this function will not work if a cell has not been selected.



	Increase Column Span

After the table is created, you can increase the span of a specific column/s with this command
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	To insert column span: 

1. Click inside cell who's span is to be increased

2. Click the Table menu and ten click the 'Increase Column Span' option.


Each consecutive click will further increase the column span of selected cell.

Note: this function will not work if a cell has not been selected.



	Decrease Column Span

After the table is created, you can decrease the span of a specific column/s with this command
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	To decrease column span: 

1. Click inside cell who's span is to be decreased

2. Click the Table menu and ten click the 'Decrease Column Span' option.


Each consecutive click will further decrease the column span of the selected cell. Note: this function will not work if a cell has not been selected.



	Insert Special Characters

You may find that you need to insert some characters that are not available on your keyboard yet are commonly used. You can choose from a selection of special characters that are available in this drop down menu.
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	To insert a special character:

1. Click the Insert menu and then click the 'Insert Special Character…' option. A pop-up window will appear with a list of special characters.

2. Click the icon of the character to insert



	Modify Page Properties

This command allows you to modify the properties of your web page. 

Title: the title of the web page (not the filename)- this will appear at the top of the users’ browser window.

Description: a short description that outlines what the page displays/contains

Keywords: the keywords that are contained in the page

Background color: choose a color from the drop down list that will be set as the background color of the page.

Text color: the default text color of the page

Link color: the color that the links on the page will appear. The link color needs to be distinguished from other text so that visitors to your site will know that it is a link.

Visited link color: the color that the link will change to once a visitor to your page has clicked on it once (this is useful for visitors to your page, as it allows them to keep track of which links they have already visited (especially useful if there are many links)

Active link color: the color a link turns when your mouse is clicking on it.
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	To modify page properties:

1. Click the 'Modify Page Properties' icon. A pop-up window will appear with page attributes: Page Title - title of page; Description - description of page; Background Image - The URL of the image currently set as the page background image; Keywords - keywords page is to be recognized by; Background Color - the background color of page; Text Color - color of text in page and Link Color - the color of links in page.

2. When finished modifying, click the 'Modify Page' button to save changes, or click 'Cancel' to go back to the editor.



	Clean HTML Code

This command allows you to clean out tags and messy code from your HTML to optimise your page.
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	To clean HTML:

1. Click the Tools menu and then click the ‘Clean HTML Code' option. This will remove any empty span and paragraph tags, all xml tags, all tags that have a colon in the tag name (i.e. <tag:with:colon>) and remove style and class attributes.


	Paste From Microsoft Word

When copying from Microsoft word, tags are added that you don’t need. When you copy an item from Microsoft Word and paste using this button, all unnecessary formatting is removed.
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	To paste from Microsoft Word:

1. Click the Edit menu, then click the Paste sub-menu. Finally, click the ‘Paste from Word’ option. This will remove the tags that Microsoft Word automatically places and removes any of the formatting as well all in the one action.

 

	Switch Editing Mode 

This command allows you to switch from the WYSIWYG editor to the HTML that the page will comprise of, and back again. This feature is designed for users that have knowledge of HTML and want to see how the HTML looks for specific operations or perform certain operations directly through the HTML and not through the WYSIWYG editor. 
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	To switch between editing modes (Ctrl+tab):

1. Click the View menu and then click the 'toggle mode' option. This will toggle between the editing modes (Text - showing all the HTML or WYSIWYG - showing the content of the page).


NB: This is recommended for advanced users only. 



	Show / Hide Guidelines

This command allows you to view that sections of your page are within tables and within forms. It is handy for grouping and ungrouping your contents and for viewing the organization of your page’s contents.
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	To show or hide guidelines:

1. Click the View menu then click the 'Toggle Table Guidelines' option. This will toggle between displaying table and form guidelines and not showing any guidelines at all.

Tables and cells will have a broken gray line around them, forms will have a broken red line around them, while hidden fields will be a pink square when showing guidelines.

Note that the status bar (at the bottom of the window) will reflect the guidelines mode currently in use.




WORKING WITH IMAGES

Images on the web

Images are used to add photos and animations (such as your company’s logo and product pictures)
to your web pages.

It is important to use always an image size that is not too big. 

600 x 600 pixels or less.

There are two main types of image files you will use, ‘.gif’ and ‘.jpeg/.jpg’.

GIF is an acronym is for Graphics Interchange Format, created so that images could be exchanged regardless of which operating system you were on. The file format is known for its compression and the fact that it can store and display multiple images for animation. The major drawback to GIF is that images that images are displayed with less colors than JPEG files, which doesn’t make GIF’s the best choice for photographic images. 

You would choose the .GIF format for:

· Images with a transparent background.

· Animated graphics

· Less complex images containing 256 colors or less


JPEG/JPG is an acronym for (developed by) theJoint Photographic Experts Group. This file format is the Internet standard for presenting photo realistic images. It has the capability to compress large images down to very small file sizes while retaining the overall photographic quality of the image. 


You would choose the .JPG format for:


· Photographs

· More complex images

·  When you can get better quality AND a smaller file size (using a method called compression)

Like HTML files, image files also have a filename.extension. For example:

· smile.jpg is a JPEG (a compressed digital image file format) named “smile”

· laugh.gif is a GIF (a graphics file format) named “laugh”.

Image Manager


The Image Manager is similar to the File Manager, the difference being - it is an area where you can see your image files and image folders. In the image manager you will see:

· The name and optionally a preview shot of the image for quick reference.

· The size of your images.

· When you put your mouse over certain text or icons, a comment will appear which tells you what clicking on the link will do. Links are view, insert, backgd, rename, copy and delete.

Note that image files are not editable in this editor.

The image manager allows you to organize your image files into relevant groups of folders. This software application has a very simple to use, yet powerful Image Manager that makes it easy to organize your image files and folders.


For Images you can:

	- Insert
	- Set as background
	- Upload

	- View
	- Copy
	- Rename

	- Delete
	
	


All folders are represented with the folder   [image: image55.emf]

    icon and files all image files have a small preview.
The Current Working Directory, located directly above the Images, will at all times reflect your current location in the file system, relative to your document root.

Uploading an Image

You may want to upload an image to keep it handy in the image manager for inserting into your web pages. You can upload an image for later use or to insert into your pages as many times as needed. Your uploaded images can be viewed as thumbnails (smaller versions of the actual image – for easy browsing).

To upload an image:

1. Click the 'Upload Image' button at the bottom of the Image Browser. This will take you to another screen that prompts for an image to upload.

2. Click the 'Browse' button to open a 'Choose File' box that allows you to select a local image to upload.

3. Once the file has been selected, click 'OK' to begin uploading the file, or click 'Cancel' to be taken back to the Image Manager

Upon successful upload of the image, you will be taken back to the Image Manager.


If the image is in an invalid format an error message will appear:


If the name of the image you are uploading already exists, you will get an error message and you will need to rename the image before uploading it.
Once your image has been successfully uploaded, you will receive the following message: Uploaded successfully.

Viewing an Image


You may need to view an image to see what it will look like when displayed on your website. Viewing an image doesn’t change it.

To view an image:

1. Select the desired image and click on the View [image: image56.emf]

 icon. The image will be shown in a pop-up window in its full size.

Close the window to return to the Image Manager


Inserting an Image

Once you have uploaded an image, you can insert it where you need to. Just select the area on your page you want the image, and select browse the images to select the image you need.

To insert an image:

Click the 'Insert' link in the image browser next to the image to be inserted.

Set background Image


There may be a certain image you have uploaded that you want to set as the background image of your web page. 

To set an image as a background image:

Click the Background [image: image57.emf]

 icon in the image browser next to the image to be set. 

The image will be set as the current page background image.


Renaming an Image or a Folder

When creating a file or folder, you may have chosen a name that you then decide is not appropriate or needs to be changed to reflect its contents or context better. The ‘rename’ function will allow you to easily change the name of the file or folder as you require.

To rename:

1. Select the desired image or folder and click on the Rename [image: image58.emf]

 icon. This will take you to another screen that requires a new name for the image/folder.

2. Enter a valid name and click 'OK' to rename, or click 'Cancel' to be taken back to the Image Manager. Valid image names consist of 


- Alphanumeric characters (a-z, A-Z 0-9)


- The underscore '_' or a dash '-'.


- MUST have a single dot '.' and be followed by an extension.

Valid image extensions are specified in the configuration file.

Deleting an Image file or Folder


You may no longer have a need for a certain file or folder. You can choose to keep it, or if you are sure it doesn’t need to be used again, you can PERMANENTLY delete it. Only use the delete function if you are sure you do not need the file/folder and its contents.

To delete:

1. Select the desired image or folder and click on the 'Delete' link. You will be prompted for confirmation of the deletion.

2. If you are sure you wish to delete the selected image/folder, click 'OK'. Clicking on 'Cancel' will take you back to the Image Manager.

Copying an Image file

If you need two or more files that are similar, or need to copy the contents of a file or folder to make modifications, you will need to copy them.

1. Click on the ‘copy’ link corresponding to the file or folder that you wish to copy

2. For files: Enter the name of the new file you wish to copy to, in the format filename.extension

For folders: Enter the name of the new folder that you with to copy to.

3. Click on ‘Ok’ to copy (Or Click ‘cancel’ to return to the previous screen)


For files, if the new file name you entered an invalid file name, an error message will appear and you will need to enter a valid filename: 


If the new file or folder name you entered already exists, you will receive an error message and you will need to enter another name for the new file/folder name:

Once your file or folder has been successfully created, you will receive the following message: copied successfully
SHORTCUT KEY INDEX


· ‘Ctrl’ is the abbreviation of the ‘control’.
The ‘ctrl’ key is situated on the bottom left of your keyboard

· ‘+’ indicates to hold ‘ctrl’ down whilst pressing the character specified on the right of the plus sign.

	Function
	Shortcut Keys

	Editor

	Bold
	Ctrl + b

	Copy
	Ctrl + c

	Cut
	Ctrl + x

	Insert Form
	Ctrl + m

	Insert Table 
	Ctrl + t

	Italic
	Ctrl + i

	Paste
	Ctrl + v

	Preview (800 x 600)
	Ctrl + F12

	Redo
	Ctrl + y

	Save
	Ctrl + s

	Switch editing modes
	Ctrl + Tab

	Underline
	Ctrl + u

	Undo
	Ctrl + z

	File Manager

	Create a New File
	Ctrl + F10

	Create a New Folder
	Ctrl + F11

	Upload a File
	Ctrl + F9
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